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CSerrrman jordanian Univers

Computing Fundamentals CS1150 Lab NO. 3: MS PowerPoint

Objectives:

1.

2.

Describe a Data Model in Power Point
a. Use bullets
Show one bullet at a time
Use different sorts of transitions between slides
Use sound for certain slides
Try out different templates/ themes for our slideshow
Hide certain slides then unhide them again
g. Start slide show from beginning and from current slide
Draw the Data Model in Power Point

o

3. Animate the Data Model elements in Power Point

Introduction

Power Point is an MS Office tool which is intended to present a topic to audience through a
slide show. It has features which enable you to impress the targeted audience by animating
objects on the slides, changing transitions from one slide to another and issuing sound as you
enter certain slides, among other features.

In this assignment, you will:

Create a new slideshow in Power Point.

Describe a Data Model in your slide show using text arranged in bullets.

Draw an Entity Relationship Diagram (ERD) for your model

Derive a Conceptual Schema from the ERD and draw it

Animate certain elements in the drawings you created in the above two points
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Description of Business Requirements Hospital Data Requirements:

A hospital keeps records of its patients and their treatment by doctors. A patient is typically assigned
to one Doctor, but he/ she can receive treatment from specialists other than his/ her standard doctor.
Doctors give treatments to patients. According to a treatment, a Doctor prescribes drugs.
Patients can stay in wards (hospital rooms), which have a certain capacity of a number of patients. As
for wards, a ward is staffed by a number of nurses.

Data Modeling Discussion

According to the business specification above, we have the following entities:

Doctor
Patient
Treatment
Drug
Ward
Nurse

After figuring out our entities, we need to specify the attributes for each one.

Doctor’s attributes: DocID, Name, Specialty

Patient’s attributes: PatientlD, Name, gender, birthdate
Treatment attributes: TreatmentID, Date, Time, Diagnosis
Drug attributes: DruglD, Name, Company

Ward attributes: WardID, Capacity

Nurse attributes: NurselD, Name, Gender

Now we need to specify the Primary Key (PK) for each Entity:

Doctor’s PK is DocID

Patient’s PK is PatientID
Treatment’s PK is TreatmentID
Drug’s PK is DrugID

Ward’s PK is WardID

Nurse’s PK is NurselD

Then we need to identify the relationships between Entities:

Doctor/ Patient Relationship:

o A Doctor is responsible for many Patients.

o A Patient is assigned to one Doctor
Doctor/ Treatment Relationship:

o A Doctor gives many treatments o A Treatment is given by one Doctor
Patient/ Treatment Relationship o A Patient receives many treatments o A Treatment is given to
one Patient
Treatment/ Drug Relationship o A Treatment results in prescribing many Drugs o A Drug can be
prescribed according to many treatments
Patient/ Ward Relationship o A Patient stays in a Ward o A Ward can accommodate many
patients
Nurse/ Ward Relationship o A Ward is staffed by many Nurses o A Nurse Staffs only one Ward
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Task 1:

Open MS Power Point and create a new Slide Show.
On slidel write the title: Hospital Data Model. In the text below the title, write your name and the date.
Make a new slide (as a shortcut press CTRL+M). Write the title on this slide (slide2) as “Entities and their
Attributes”
List the entities specified above with their attributes as bullets. Each entity should go with the big bullet,
and its attributes indented to the right as sub-bullets. In power point, text is bulleted by default. To make
a sub-bullet, just press the Tab key. To go back to a big bullet, click on your sub-bullet and move it to the
left by dragging your mouse left.
For example, list the Doctor entity and its attributes to look as follows:

The Doctor Entity:

o DoclD
o Name
o Specialty

After listing your Entities and their Attributes, make an entity and its attributes appear one at a time. To
do so, select the Entity and its Attributes, then click on the Animations tab on the main Ribbon, then in
Animations group choose custom animation. A Custom Animation Pane will appear to the right. Click on
Add Effect and choose any one of the Entrance options that you like)

i “ Animations 1 Shde Show Remw Format — — - @
s& Transition Sound: | [No Sound] v | Advance Slide ‘
! ! ﬁ] Transition Speed:  Fast ~ | ¥ On Mouse Click
¥ 38 Apply To All | 7 Automatically After: |00:00 ol
Transition'to This Slide
Custom Animation NG5S
[;}ﬁ( Add Effect V] l‘:',; Remove ]
Modify: Diamond. -
Click to add title P e | 5
Directiont: |1 B‘
o ' et vedm 3]
"1+ The Doctor Entity: | 1% 3k The Doctor Entit:
| | 3
| —DoclD | i
|
'\ —Name l ey
| . ! 3k The Patient Entity:
| = Spec1alty ! 275 Sk The Patient Entity:
72! = 2 I Sk PatientlD
24+ The Patient Entity: L e
| o ! :
| —PatientID | i conde
i : : 3k Birthdate [«]
L= Name ]
|
| —Gender !
! |
| —Birthdate |
|
L e )
[#] Re-order (&)
» play | |EJ slide Show

Run you slideshow, which so far consists of two slides. Show your work to the teacher/ TA.
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Task 2:

On the same slide show you created above, make a new slide (CTRL+M). This will be slide3. On this slide,
delete the default text boxes and draw the Entity Relationship Diagram, making use of the Data Modeling
Discussion section of this assignment. An ERD is drawn according to the following specifications:

» Rectangles for Entities
» Bubbles for Attributes D

> Primary Key Attribute is underlined
» Diamond for Relationships S

» Relationship Cardinality:
= 1to 1 :represented by a straight line

~
< 1 to n : represented by a chicken foot — <<
from one side

> m to n: represented by chicken feet >_O_é
~.

from both sides

To draw in power point, choose the Home tab, then Drawing group, as shown in this screen:

= T 8 Presentationl W Bt MAodeing TUnHeg ot ) e - Y E G 25m
After finishing the ERD, run your slideshow, which now consists of 3 slides. Show your work to the teacher/
TA.
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Task 3:

From the ERD that you created, derive the Conceptual Schema. To do so, follow these guidelines:

Each entity is mapped to a table which has a name and a list of attributes, one of which is the primary key.
Usually, we list PK first.

Diamonds are removed

An m to n relationship is mapped to a new relation (table). The attributes of this new relation are the PKs
of the contributing Entities (now becoming relations). We may also need to give the new relation
additional attributes. For example, we'll need a Date attribute for Customer Order. A 1 to n relationship
causes the Primary Key from the 1 side to be a Foreign Key in the n side.

You can draw the conceptual schema by inserting a table in power point for each entity. To insert a table
in power point, go to insert tab, tables group and choose one column and two rows for your table, as
shown in the following screen.

Presentationl - Microsoft PowerPoint

Home | Insert | Design  Animations  SlideShow  Review  View @

| — = = e = —— = =
R rd @l 343000 89
| loal] B | = 168, gty Q
Picture. Clip Photo Shapes SmartArt Chart | Hyperlink Acion Text Header WordArt Date Slide Symbol Object | Movie Sound
it Albumy v \ Box &Footer v &Time Number 5 7

s | Links I Text Media Clips

£
g

O O
I O [
3 InsertTable...
74 DrawTable
43 Excel Spreadsheet

Click to add notes

English {United States) |

- RO ST ——————— PSS (=T
T20ab4- M. | B Presentationl T Data Modeling \! DrawingSnapsh... ||/ Yahoo! Mail - In... | [ Windows Medra.

The table that you insert will initially be too wide. You need to resize it to an appropriate size. You also
need to choose the appropriate style for this table. After you insert the table, the Design tab is
automatically selected for you to choose a table style. Choose table style 2 Accent 5 as in the following
screen:
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Presentationl - Microsoft PowerPoint Table Tools

Home Insert Design Animations Slide Show Review View Design Layout I @
V] Header Row [ First Column = | & shading - A& A i Zj —rj
1l TotalRow [ Last Calumn Best Match for Hooyment 22 Borders & || 1pt v = EE

= E_ Draw Eraser
V| Banded Rows || Banded Columns S b Effects ~ ZPenColor™  aple

Table Style Options iz 7 il i Wordart Styles & Draw Borders

ight Style 2 - Accent

B crearTable

Click to add notes

<  English (United States) |

2Labf- Mh... | B Presentationl €§ Data Modeling T Tablesnapshot - | 72 Vahoo! Mail - Tn.. ows Media...

In the blue header of the table write the entity name, and in the white part of the table list the attributes.
Don’t forget to give focus to the PK attribute by making it Bold and underlined. An example of how the
entity looks is:

PublisherID
Name

Address
Country

Phone Number

Draw the relationships between the entities using the same drawing tools you used in Task2. Run
your slideshow, which now consists of 4 slides. Show your work to the teacher/ TA.

Page 6 of 8



- . _
"liig < JuU

ay_a,‘;n Sl oMl ao ol il

CSermman jordanian University

Computing Fundamentals CS1150 Lab NO. 3: MS PowerPoint

Task4:

In this task, you will apply animation to the drawings you constructed in tasks 2 and 3.

In slide3, where you have the ERD, add a focusing effect to the relationships which you represented by
diamonds. To do so, make a multiple selection on all the diamonds and go to the Animations tab/
Animations group/ Custom Animation. The Custom Animation pane will appear on the right. Select Add
Effect/Emphasis/Change Fill Color as shown below:

\ Animations | ShideShow ~ Review  View | Format 2]

é& Transition Sound: IVINo Sound] ~ | | Advance Slide
g - |
| g ! » 33 Transition Speed: Fast ~ || V| on'Mouse Click
3 | 7] Automatically After; (00:00 T |

¥ 30 Apply To All

Transition to This:Slide.

The Bookstore Example
Entity Relatlonshlﬁ Dlagram (ERLC’

2

A
(T:(Ie > A 3
% - B

B d

| Custom Animation

Entrance

»
¢ Emphasis »
= it » |
Motion Paths »

QD ) (Name >

\ \

4, Change Font Style

5. Flash Bulb
6. Grow/Shrink
#% 1.Spin

Select an element of the slide, then
dlick %Add Effect” to add animation.

Publisher

More Effects...

== @;)

@ po— m // Ordered\
ComPy Customer [ . ;
., ordered

- \\by /

Sy, P

S Frone
~ [&] reitrder (9]
> o & siide show

After that, go to slide4 to make animation effects on it. Make a multiple selection on all the entities in the
Conceptual Schema, then click on Add Effect in the Custom Animation pane, choose Entrance and
Diamond as shown below:
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The Bookstore Example T ;
S 2.Box %% Emphasis »
Conceptual Schema < e - i
. = 3% 4. Diamond % Motion Paths »
1 & 5.Fyh
ISBN More Effects... Select an element of the side, then
PublisherlD | PublisherD = ik Aakd Effect o adkd animaton,
| Name : . ‘Tltle g
| Address Author
Country Category

| Phone Number | Price

Customer Bool |
: Name : ,

" Address —— ~— CustomeriD
Country ISBN
' Phone Number :-OrderDate

(#] reoder (@

2 | [E3 side show

Then do a multiple selection on all the relationship lines and give them the same animation effect that you
chose above. Run your slide show and show your work to the teacher/TA.

Task 5:

Now it’s time to apply Themes and choose transition styles for your slides. It’s also time to customize
navigation between slides.

Go to slide 2 and put two custom action buttons. Label one of the “View ERD” and label the other “View
Schema”. Specify the action of the first one to go to the ERD slide. Specify the action of the other one to go
to the slide which has the conceptual schema.

On the Animations tab/ Transition to This Slide group, choose the transition that you prefer for each of
your slides. Choose a transition sound only for the last slide.

| Ammatlons 1 Slide Show ew View Format

ifl, Transition Sound: | [No Sound] v |,

[ ) ) ST

v i3l Apply To All

<

Transition to This Slide

After that, choose a theme for your whole slide show. Themes are found on the Design tab in the Themes
group.

Then hide slide 3 and run the slide show. Then unhide it and run it again. The Hide option is present in the
Slide Show tab/ Set Up group.

Run the final version of your slide show and show it to the teacher/ TA.
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